]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-dns/djbdns/djbdns-1.05-r24.ebuild
Remove the "-j1" from all emake calls.
[mjo-overlay.git] / net-dns / djbdns / djbdns-1.05-r24.ebuild
index 31d1589c3193146624ff2a3748cf794ea174a375..0fce9af56257a88ec8c91d9b0dfa5478fb0f8183 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2011 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r24.ebuild,v 1.1 2011/04/04 14:05:00 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r24.ebuild,v 1.2 2011/04/04 16:57:45 c1pher Exp $
 
 EAPI="2"
 inherit eutils flag-o-matic toolchain-funcs
@@ -46,7 +46,7 @@ src_prepare() {
 
        if use ipv6; then
                elog "At present dnstrace does NOT support IPv6. It will"\
-                    "be compiled without IPv6 support."
+                        "be compiled without IPv6 support."
                cp -pR "${S}" "${S}-noipv6"
                # Careful -- >=test21 of the IPv6 patch includes the errno patch
                epatch "${DISTDIR}/${P}-${IPV6_PATCH}.diff.bz2"
@@ -83,7 +83,7 @@ src_compile() {
        echo "$(tc-getCC) ${CFLAGS}" > conf-cc
        echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
        echo "/usr" > conf-home
-       emake -j1 || die "emake failed"
+       emake || die "emake failed"
 
        # If djbdns is compiled with IPv6 support, it breaks dnstrace.
        # Therefore we must compile dnstrace separately without IPv6
@@ -94,7 +94,7 @@ src_compile() {
                echo "$(tc-getCC) ${CFLAGS}" > conf-cc
                echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
                echo "/usr" > conf-home
-               emake -j1 dnstrace || die "emake failed"
+               emake dnstrace || die "emake failed"
        fi
 }
 
@@ -118,7 +118,7 @@ src_install() {
        newbin "${FILESDIR}/djbdns-setup-r17" djbdns-setup || die
 }
 
-pkg_setup() {
+pkg_preinst() {
        # The nofiles group is provided by baselayout
        enewuser dnscache -1 -1 -1 nofiles
        enewuser dnslog -1 -1 -1 nofiles