]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - app-text/XML-Schema-learner/XML-Schema-learner-1.0.0.ebuild
Rename the XML-Schema-learner ebuild to reflect the static version.
[mjo-overlay.git] / app-text / XML-Schema-learner / XML-Schema-learner-1.0.0.ebuild
diff --git a/app-text/XML-Schema-learner/XML-Schema-learner-1.0.0.ebuild b/app-text/XML-Schema-learner/XML-Schema-learner-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..6e5e1f4
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
+HOMEPAGE="https://github.com/kore/${PN}"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# PHP dependency can be inferred from .travis.yml in the repository.
+DEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php[cli,xml,xmlreader]"
+
+src_compile() {
+       # Don't run make, the default target is 'check'.
+       :
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="/usr" install
+}