]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - app-misc/reptyr/reptyr-0.2.ebuild
Added an ebuild for reptyr.
[mjo-overlay.git] / app-misc / reptyr / reptyr-0.2.ebuild
diff --git a/app-misc/reptyr/reptyr-0.2.ebuild b/app-misc/reptyr/reptyr-0.2.ebuild
new file mode 100644 (file)
index 0000000..eaf360e
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+DESCRIPTION="Reparent a running program to a new terminal"
+HOMEPAGE="https://github.com/nelhage/${PN}"
+SRC_URI="http://github.com/nelhage/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+       unpack ${A}
+       mv "nelhage-${PN}"-* "${S}"
+}
+
+src_compile() {
+       emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="/usr" install || die "install failed"
+}