]> gitweb.michael.orlitzky.com - xfce4-hdaps.git/blobdiff - panel-plugin/Makefile.am
COPYING: update license to AGPL-3.
[xfce4-hdaps.git] / panel-plugin / Makefile.am
index e9632fe0435892efe9cd1268afe775a453c58a5f..eb9e93d6fb4cb72c8c6587ea24a1ee894e3e8855 100644 (file)
@@ -1,24 +1,24 @@
 #
 # xfce4-hdaps, an XFCE4 panel plugin for the HDAPS system.
 #
-# Copyright Michael Orlitzky
+# Copyright (C) 2019 Michael Orlitzky
 #
-# http://michael.orlitzky.com/
+#   http://michael.orlitzky.com/
 #
 # This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
+# it under the terms of the GNU Affero General Public License as
+# published by the Free Software Foundation, either version 3 of the
+# License, or (at your option) any later version.
 #
 # This program is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU Affero General Public License for more details:
 #
-# http://www.fsf.org/licensing/licenses/gpl.html
+#   https://www.gnu.org/licenses/agpl-3.0.html
 #
 
-INCLUDES =                                                             \
+AM_CPPFLAGS =                                                          \
        -I$(top_srcdir)                                                 \
        -DG_LOG_DOMAIN=\"xfce4-hdaps\"                                  \
        -DPACKAGE_LOCALE_DIR=\"$(localedir)\"                           \
@@ -27,13 +27,11 @@ INCLUDES =                                                          \
 #
 # HDAPS plugin
 #
-plugin_PROGRAMS =                                                      \
-       xfce4-hdaps
+plugin_LTLIBRARIES = libhdaps.la
 
-plugindir =                                                            \
-       $(libexecdir)/xfce4/panel-plugins
+plugindir = $(libdir)/xfce4/panel/plugins
 
-xfce4_hdaps_SOURCES =                                          \
+libhdaps_la_SOURCES =                                          \
        hdaps.c                                                 \
        hdaps.h                                                 \
        xfce4-hdaps.c                                           \
@@ -41,42 +39,38 @@ xfce4_hdaps_SOURCES =                                               \
        xfce4-hdaps-dialogs.c                                   \
        xfce4-hdaps-dialogs.h
 
-xfce4_hdaps_CFLAGS =                                           \
-       $(LIBXFCE4UTIL_CFLAGS)                                          \
-       $(LIBXFCE4UI_CFLAGS)                                            \
-       $(LIBXFCE4PANEL_CFLAGS)                                         \
+libhdaps_la_CFLAGS =                                           \
+       $(LIBXFCE4UTIL_CFLAGS)                                  \
+       $(LIBXFCE4UI_CFLAGS)                                    \
+       $(LIBXFCE4PANEL_CFLAGS)                                 \
        $(PLATFORM_CFLAGS)
 
-xfce4_hdaps_LDADD =                                            \
-       $(LIBXFCE4UTIL_LIBS)                                            \
-       $(LIBXFCE4UI_LIBS)                                              \
+libhdaps_la_LDFLAGS =                                                       \
+       -avoid-version                                                      \
+       -module                                                             \
+       -no-undefined                                                       \
+       -export-symbols-regex '^xfce_panel_module_(preinit|init|construct)' \
+       $(PLATFORM_LDFLAGS)
+
+libhdaps_la_LIBADD =                                           \
+       $(LIBXFCE4UTIL_LIBS)                                    \
+       $(LIBXFCE4UI_LIBS)                                      \
        $(LIBXFCE4PANEL_LIBS)
 
 #
 # Desktop file
 #
-desktopdir =                                                           \
-       $(datadir)/xfce4/panel-plugins
-
-desktop_in_in_files =                                                  \
-       xfce4-hdaps.desktop.in.in
-
-desktop_in_files =                                                     \
-       $(desktop_in_in_files:.desktop.in.in=.desktop.in)
+desktopdir = $(datadir)/xfce4/panel/plugins
 
-%.desktop.in: %.desktop.in.in
-       sed -e "s,\@libexecdir\@,$(libexecdir),g" < $< > $@
+desktop_in_files = hdaps.desktop.in
 
-desktop_DATA =                                                         \
-       $(desktop_in_files:.desktop.in=.desktop)
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
 
 @INTLTOOL_DESKTOP_RULE@
 
-EXTRA_DIST =                                                           \
-       $(desktop_in_in_files)
+EXTRA_DIST = $(desktop_in_files)
 
 CLEANFILES =                                                           \
-       $(desktop_in_files)                                             \
        $(desktop_DATA)
 
 # vi:set ts=8 sw=8 noet ai nocindent syntax=automake: