]> gitweb.michael.orlitzky.com - xfce4-hdaps.git/blobdiff - panel-plugin/Makefile.am
Rename the desktop file to match the naming scheme of those that ship
[xfce4-hdaps.git] / panel-plugin / Makefile.am
index e9632fe0435892efe9cd1268afe775a453c58a5f..8dc27dee471233658f47f96bbbd7bc30447c0cd8 100644 (file)
@@ -27,13 +27,11 @@ INCLUDES =                                                          \
 #
 # HDAPS plugin
 #
-plugin_PROGRAMS =                                                      \
-       xfce4-hdaps
+plugin_LTLIBRARIES = libhdaps.la
 
-plugindir =                                                            \
-       $(libexecdir)/xfce4/panel-plugins
+plugindir = $(libdir)/xfce4/panel/plugins
 
-xfce4_hdaps_SOURCES =                                          \
+libhdaps_la_SOURCES =                                          \
        hdaps.c                                                 \
        hdaps.h                                                 \
        xfce4-hdaps.c                                           \
@@ -41,39 +39,36 @@ xfce4_hdaps_SOURCES =                                               \
        xfce4-hdaps-dialogs.c                                   \
        xfce4-hdaps-dialogs.h
 
-xfce4_hdaps_CFLAGS =                                           \
-       $(LIBXFCE4UTIL_CFLAGS)                                          \
-       $(LIBXFCE4UI_CFLAGS)                                            \
-       $(LIBXFCE4PANEL_CFLAGS)                                         \
+libhdaps_la_CFLAGS =                                           \
+       $(LIBXFCE4UTIL_CFLAGS)                                  \
+       $(LIBXFCE4UI_CFLAGS)                                    \
+       $(LIBXFCE4PANEL_CFLAGS)                                 \
        $(PLATFORM_CFLAGS)
 
-xfce4_hdaps_LDADD =                                            \
-       $(LIBXFCE4UTIL_LIBS)                                            \
-       $(LIBXFCE4UI_LIBS)                                              \
+libhdaps_la_LDFLAGS =                                                       \
+       -avoid-version                                                      \
+       -module                                                             \
+       -no-undefined                                                       \
+       -export-symbols-regex '^xfce_panel_module_(preinit|init|construct)' \
+       $(PLATFORM_LDFLAGS)
+
+libhdaps_la_LIBADD =                                           \
+       $(LIBXFCE4UTIL_LIBS)                                    \
+       $(LIBXFCE4UI_LIBS)                                      \
        $(LIBXFCE4PANEL_LIBS)
 
 #
 # Desktop file
 #
-desktopdir =                                                           \
-       $(datadir)/xfce4/panel-plugins
-
-desktop_in_in_files =                                                  \
-       xfce4-hdaps.desktop.in.in
-
-desktop_in_files =                                                     \
-       $(desktop_in_in_files:.desktop.in.in=.desktop.in)
+desktopdir = $(datadir)/xfce4/panel/plugins
 
-%.desktop.in: %.desktop.in.in
-       sed -e "s,\@libexecdir\@,$(libexecdir),g" < $< > $@
+desktop_in_files = hdaps.desktop.in
 
-desktop_DATA =                                                         \
-       $(desktop_in_files:.desktop.in=.desktop)
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
 
 @INTLTOOL_DESKTOP_RULE@
 
-EXTRA_DIST =                                                           \
-       $(desktop_in_in_files)
+EXTRA_DIST = $(desktop_in_files)
 
 CLEANFILES =                                                           \
        $(desktop_in_files)                                             \