]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sci-mathematics/rw/rw-0.7.ebuild
sci-mathematics/rw: commit kiwifb's changes from sage-on-gentoo.
[mjo-overlay.git] / sci-mathematics / rw / rw-0.7.ebuild
index 37d615e2133c750e37d11c7fb82b4266e526a435..59cf2d613ad3b373272c8d445f781c8924b0e7f8 100644 (file)
@@ -4,6 +4,8 @@
 
 EAPI=5
 
+inherit autotools-utils
+
 DESCRIPTION="Compute rank-width decompositions of graphs"
 AUTHORPAGE="http://pholia.tdi.informatik.uni-frankfurt.de/~philipp/"
 HOMEPAGE="${AUTHORPAGE}software/${PN}.shtml"
@@ -11,17 +13,23 @@ SRC_URI="${AUTHORPAGE}/software/${P}.tar.gz"
 
 LICENSE="GPL-2+"
 SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+executable"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
+IUSE="+executable static-libs"
 
 DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
 RDEPEND="${DEPEND}"
 
 DOCDIR="/usr/share/doc/${PF}"
 
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
 src_configure(){
-       econf $(use_enable executable) \
-                 --docdir="${EPREFIX}${DOCDIR}"
+       local myeconfargs=(
+               $(use_enable executable)
+               --docdir="${EPREFIX}${DOCDIR}"
+       )
+
+       autotools-utils_src_configure
 }
 
 src_install(){
@@ -29,5 +37,5 @@ src_install(){
        # program. The rest of the docs are small so just leave everything
        # uncompressed.
        docompress -x "${DOCDIR}"
-       default
+       autotools-utils_src_install
 }