]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sci-mathematics/rw/rw-0.7.ebuild
sci-mathematics/rw: mangle the 'rw' ebuild some more.
[mjo-overlay.git] / sci-mathematics / rw / rw-0.7.ebuild
index 91d52f474f3d7e43bb3fd35e9683ed4e07922cc9..37d615e2133c750e37d11c7fb82b4266e526a435 100644 (file)
@@ -11,12 +11,23 @@ SRC_URI="${AUTHORPAGE}/software/${P}.tar.gz"
 
 LICENSE="GPL-2+"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="executable"
+KEYWORDS="~amd64"
+IUSE="+executable"
 
 DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
 RDEPEND="${DEPEND}"
 
+DOCDIR="/usr/share/doc/${PF}"
+
 src_configure(){
-       econf $(use_enable executable)
+       econf $(use_enable executable) \
+                 --docdir="${EPREFIX}${DOCDIR}"
+}
+
+src_install(){
+       # The examples graphs are meant to be fed uncompressed into the 'rw'
+       # program. The rest of the docs are small so just leave everything
+       # uncompressed.
+       docompress -x "${DOCDIR}"
+       default
 }