]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.9.ebuild
Add an "any slot" dependency operator for dev-db/postgresql.
[mjo-overlay.git] / dev-lang / php / php-5.6.9.ebuild
index 892f2ffc203048016a463a068029cb3e5c0dfa5e..f1492eba3bbf5892ac7d421d36ccb99baa6d6ff5 100644 (file)
@@ -116,7 +116,7 @@ DEPEND="
        nls? ( sys-devel/gettext )
        oci8-instant-client? ( dev-db/oracle-instantclient-basic )
        odbc? ( >=dev-db/unixODBC-1.8.13 )
-       postgres? ( dev-db/postgresql )
+       postgres? ( dev-db/postgresql:* )
        qdbm? ( dev-db/qdbm )
        readline? ( sys-libs/readline )
        recode? ( app-text/recode )
@@ -406,7 +406,7 @@ src_configure() {
        # DBA support
        if use cdb || use berkdb || use flatfile || use gdbm || use inifile \
                || use qdbm ; then
-               my_conf="${my_conf} --enable-dba${shared}"
+               my_conf+=" --enable-dba${shared}"
        fi
 
        # DBA drivers support
@@ -466,21 +466,13 @@ src_configure() {
        fi
 
        # ODBC support
-       if use odbc ; then
-               my_conf+="
-               $(use_with odbc unixODBC ${EPREFIX}/usr)"
-       fi
-
-       if use iodbc ; then
-               my_conf+="
-               $(use_with iodbc iodbc ${EPREFIX}/usr)"
-       fi
+       my_conf+="
+       $(use_with odbc unixODBC ${EPREFIX}/usr)
+       $(use_with iodbc iodbc ${EPREFIX}/usr)"
 
        # Oracle support
-       if use oci8-instant-client ; then
-               my_conf+="
-               $(use_with oci8-instant-client oci8)"
-       fi
+       my_conf+="
+       $(use_with oci8-instant-client oci8)"
 
        # PDO support
        if use pdo ; then
@@ -489,11 +481,8 @@ src_configure() {
                $(use_with mysql pdo-mysql ${mysqllib})
                $(use_with postgres pdo-pgsql )
                $(use_with sqlite pdo-sqlite ${EPREFIX}/usr)
-               $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)"
-               if use oci8-instant-client ; then
-                       my_conf+="
-                       $(use_with oci8-instant-client pdo-oci)"
-               fi
+               $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)
+               $(use_with oci8-instant-client pdo-oci)"
        fi
 
        # readline/libedit support
@@ -511,12 +500,12 @@ src_configure() {
        fi
 
        # Use pic for shared modules such as apache2's mod_php
-       my_conf="${my_conf} --with-pic"
+       my_conf+=" --with-pic"
 
        # we use the system copy of pcre
        # --with-pcre-regex affects ext/pcre
        # --with-pcre-dir affects ext/filter and ext/zip
-       my_conf="${my_conf} --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
+       my_conf+=" --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
 
        # Catch CFLAGS problems
        # Fixes bug #14067.
@@ -524,7 +513,7 @@ src_configure() {
        replace-cpu-flags "k6*" "i586"
 
        # Support user-passed configuration parameters
-       my_conf="${my_conf} ${EXTRA_ECONF:-}"
+       my_conf+=" ${EXTRA_ECONF:-}"
 
        # Support the Apache2 extras, they must be set globally for all
        # SAPIs to work correctly, especially for external PHP extensions