]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.9.ebuild
Use "+=" consistently for appending to $my_conf.
[mjo-overlay.git] / dev-lang / php / php-5.6.9.ebuild
index 933d1248afb9cbb9390ab6d82ffb8210e6d4e359..3d7d87e1aee241e54acb2da083b6768c66fb5ca5 100644 (file)
@@ -406,7 +406,7 @@ src_configure() {
        # DBA support
        if use cdb || use berkdb || use flatfile || use gdbm || use inifile \
                || use qdbm ; then
        # DBA support
        if use cdb || use berkdb || use flatfile || use gdbm || use inifile \
                || use qdbm ; then
-               my_conf="${my_conf} --enable-dba${shared}"
+               my_conf+=" --enable-dba${shared}"
        fi
 
        # DBA drivers support
        fi
 
        # DBA drivers support
@@ -500,12 +500,12 @@ src_configure() {
        fi
 
        # Use pic for shared modules such as apache2's mod_php
        fi
 
        # Use pic for shared modules such as apache2's mod_php
-       my_conf="${my_conf} --with-pic"
+       my_conf+=" --with-pic"
 
        # we use the system copy of pcre
        # --with-pcre-regex affects ext/pcre
        # --with-pcre-dir affects ext/filter and ext/zip
 
        # we use the system copy of pcre
        # --with-pcre-regex affects ext/pcre
        # --with-pcre-dir affects ext/filter and ext/zip
-       my_conf="${my_conf} --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
+       my_conf+=" --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
 
        # Catch CFLAGS problems
        # Fixes bug #14067.
 
        # Catch CFLAGS problems
        # Fixes bug #14067.
@@ -513,7 +513,7 @@ src_configure() {
        replace-cpu-flags "k6*" "i586"
 
        # Support user-passed configuration parameters
        replace-cpu-flags "k6*" "i586"
 
        # Support user-passed configuration parameters
-       my_conf="${my_conf} ${EXTRA_ECONF:-}"
+       my_conf+=" ${EXTRA_ECONF:-}"
 
        # Support the Apache2 extras, they must be set globally for all
        # SAPIs to work correctly, especially for external PHP extensions
 
        # Support the Apache2 extras, they must be set globally for all
        # SAPIs to work correctly, especially for external PHP extensions