]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Use "+=" consistently for appending to $my_conf.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index e7b309815812523bfb8f39773eeecfdcd91e8533..f7a181aae946f88a7da6ff584ed3fd785d03d02c 100644 (file)
@@ -438,7 +438,7 @@ src_configure() {
        # DBA support
        if use cdb || use berkdb || use flatfile || use gdbm || use inifile \
                || use qdbm ; then
-               my_conf="${my_conf} --enable-dba${shared}"
+               my_conf+=" --enable-dba${shared}"
        fi
 
        # DBA drivers support
@@ -495,12 +495,12 @@ src_configure() {
        fi
 
        # Use pic for shared modules such as apache2's mod_php
-       my_conf="${my_conf} --with-pic"
+       my_conf+=" --with-pic"
 
        # we use the system copy of pcre
        # --with-pcre-regex affects ext/pcre
        # --with-pcre-dir affects ext/filter and ext/zip
-       my_conf="${my_conf} --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
+       my_conf+=" --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
 
        # Catch CFLAGS problems
        # Fixes bug #14067.
@@ -508,7 +508,7 @@ src_configure() {
        replace-cpu-flags "k6*" "i586"
 
        # Support user-passed configuration parameters
-       my_conf="${my_conf} ${EXTRA_ECONF:-}"
+       my_conf+=" ${EXTRA_ECONF:-}"
 
        # Support the Apache2 extras, they must be set globally for all
        # SAPIs to work correctly, especially for external PHP extensions