]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Use "+=" consistently for appending to $my_conf.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 32fd2bc2dcb9fa80dcc5e26ed1ab0c25af906e76..f7a181aae946f88a7da6ff584ed3fd785d03d02c 100644 (file)
@@ -438,7 +438,7 @@ src_configure() {
        # DBA support
        if use cdb || use berkdb || use flatfile || use gdbm || use inifile \
                || use qdbm ; then
-               my_conf="${my_conf} --enable-dba${shared}"
+               my_conf+=" --enable-dba${shared}"
        fi
 
        # DBA drivers support
@@ -477,16 +477,14 @@ src_configure() {
        my_conf+=" $(use_with mysql mysql $mysqllib)"
        my_conf+=" $(use_with mysqli mysqli $mysqlilib)"
 
-       local mysqlsock=" $(use_with mysql mysql-sock ${EPREFIX}/var/run/mysqld/mysqld.sock)"
-       if use mysql ; then
-               my_conf+="${mysqlsock}"
-       elif use mysqli ; then
-               my_conf+="${mysqlsock}"
-       fi
-
        # MySQL PDO support
        my_conf+=" $(use_with pdo-mysql pdo-mysql ${mysqllib})"
 
+       # If MySQL is enabled in any way, pass --with-mysql-sock to ./configure.
+       if use mysql || use mysqli || use pdo-mysql ; then
+               my_conf+=" --with-mysql-sock=${EPREFIX}/var/run/mysqld/mysqld.sock"
+       fi
+
        # Session support
        if use session ; then
                my_conf+="
@@ -497,12 +495,12 @@ src_configure() {
        fi
 
        # Use pic for shared modules such as apache2's mod_php
-       my_conf="${my_conf} --with-pic"
+       my_conf+=" --with-pic"
 
        # we use the system copy of pcre
        # --with-pcre-regex affects ext/pcre
        # --with-pcre-dir affects ext/filter and ext/zip
-       my_conf="${my_conf} --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
+       my_conf+=" --with-pcre-regex=${EPREFIX}/usr --with-pcre-dir=${EPREFIX}/usr"
 
        # Catch CFLAGS problems
        # Fixes bug #14067.
@@ -510,7 +508,7 @@ src_configure() {
        replace-cpu-flags "k6*" "i586"
 
        # Support user-passed configuration parameters
-       my_conf="${my_conf} ${EXTRA_ECONF:-}"
+       my_conf+=" ${EXTRA_ECONF:-}"
 
        # Support the Apache2 extras, they must be set globally for all
        # SAPIs to work correctly, especially for external PHP extensions