]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Add the pdo-sqlite USE flag.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index a0e6dae00ee0a68792155f802ccfb72f2783bad7..ee5945936a8d34751e4eab0ec54d81dd21fbcbbb 100644 (file)
@@ -69,7 +69,7 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit mhash
        mssql mysql libmysqlclient mysqli nls
-       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-pgsql
+       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-pgsql pdo-sqlite
        +phar +posix postgres qdbm readline recode selinux +session sharedmem
        +simplexml snmp soap sockets spell sqlite ssl
        sybase-ct sysvipc systemd tidy +tokenizer truetype unicode vpx wddx
@@ -180,6 +180,7 @@ REQUIRED_USE="
 
        pdo-dblib? ( mssql )
        pdo-pgsql? ( postgres )
+       pdo-sqlite? ( sqlite )
        qdbm? ( !gdbm )
        readline? ( !libedit )
        recode? ( !imap !mysql !mysqli )
@@ -378,6 +379,7 @@ src_configure() {
        $(use_enable pdo pdo )
        $(use_with   pdo-dblib pdo-dblib )
        $(use_with   pdo-pgsql pdo-pgsql )
+       $(use_with   pdo-sqlite pdo-sqlite "${EPREFIX}"/usr)
        $(use_enable phar phar )
        $(use_enable posix posix )
        $(use_with   postgres pgsql "${EPREFIX}"/usr)
@@ -466,7 +468,6 @@ src_configure() {
        if use pdo ; then
                my_conf+="
                $(use_with mysql pdo-mysql ${mysqllib})
-               $(use_with sqlite pdo-sqlite ${EPREFIX}/usr)
                $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)"
                if use oci8-instant-client ; then
                        my_conf+="