]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Fix --with-mysql-sock handling.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index d3a34aa13f1f5a093ed73102a8d8cabd61825086..e7b309815812523bfb8f39773eeecfdcd91e8533 100644 (file)
@@ -481,10 +481,9 @@ src_configure() {
        my_conf+=" $(use_with pdo-mysql pdo-mysql ${mysqllib})"
 
        # If MySQL is enabled in any way, pass --with-mysql-sock to ./configure.
-       local mysqlsock="${EPREFIX}/var/run/mysqld/mysqld.sock"
-       my_conf+=" $(use_with mysql mysql-sock $mysqlsock)"
-       my_conf+=" $(use_with mysqli mysql-sock $mysqlsock)"
-       my_conf+=" $(use_with pdo-mysql mysql-sock $mysqlsock)"
+       if use mysql || use mysqli || use pdo-mysql ; then
+               my_conf+=" --with-mysql-sock=${EPREFIX}/var/run/mysqld/mysqld.sock"
+       fi
 
        # Session support
        if use session ; then