]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Fix --with-mysql-sock handling.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 32fd2bc2dcb9fa80dcc5e26ed1ab0c25af906e76..e7b309815812523bfb8f39773eeecfdcd91e8533 100644 (file)
@@ -477,16 +477,14 @@ src_configure() {
        my_conf+=" $(use_with mysql mysql $mysqllib)"
        my_conf+=" $(use_with mysqli mysqli $mysqlilib)"
 
-       local mysqlsock=" $(use_with mysql mysql-sock ${EPREFIX}/var/run/mysqld/mysqld.sock)"
-       if use mysql ; then
-               my_conf+="${mysqlsock}"
-       elif use mysqli ; then
-               my_conf+="${mysqlsock}"
-       fi
-
        # MySQL PDO support
        my_conf+=" $(use_with pdo-mysql pdo-mysql ${mysqllib})"
 
+       # If MySQL is enabled in any way, pass --with-mysql-sock to ./configure.
+       if use mysql || use mysqli || use pdo-mysql ; then
+               my_conf+=" --with-mysql-sock=${EPREFIX}/var/run/mysqld/mysqld.sock"
+       fi
+
        # Session support
        if use session ; then
                my_conf+="