]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Fix MySQL socket path when USE=mysqli or USE=pdo-mysql.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 32fd2bc2dcb9fa80dcc5e26ed1ab0c25af906e76..d3a34aa13f1f5a093ed73102a8d8cabd61825086 100644 (file)
@@ -477,16 +477,15 @@ src_configure() {
        my_conf+=" $(use_with mysql mysql $mysqllib)"
        my_conf+=" $(use_with mysqli mysqli $mysqlilib)"
 
        my_conf+=" $(use_with mysql mysql $mysqllib)"
        my_conf+=" $(use_with mysqli mysqli $mysqlilib)"
 
-       local mysqlsock=" $(use_with mysql mysql-sock ${EPREFIX}/var/run/mysqld/mysqld.sock)"
-       if use mysql ; then
-               my_conf+="${mysqlsock}"
-       elif use mysqli ; then
-               my_conf+="${mysqlsock}"
-       fi
-
        # MySQL PDO support
        my_conf+=" $(use_with pdo-mysql pdo-mysql ${mysqllib})"
 
        # MySQL PDO support
        my_conf+=" $(use_with pdo-mysql pdo-mysql ${mysqllib})"
 
+       # If MySQL is enabled in any way, pass --with-mysql-sock to ./configure.
+       local mysqlsock="${EPREFIX}/var/run/mysqld/mysqld.sock"
+       my_conf+=" $(use_with mysql mysql-sock $mysqlsock)"
+       my_conf+=" $(use_with mysqli mysql-sock $mysqlsock)"
+       my_conf+=" $(use_with pdo-mysql mysql-sock $mysqlsock)"
+
        # Session support
        if use session ; then
                my_conf+="
        # Session support
        if use session ; then
                my_conf+="