]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Combine readline/libedit and other use_with statements.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 371a080e99cd06b1290e4a48b81bc5c3427b69b3..c76611dd571aaac553db5b597f6ac65e649593ba 100644 (file)
@@ -365,6 +365,7 @@ src_configure() {
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
        $(use_with   ldap ldap "${EPREFIX}"/usr)
        $(use_with   ldap-sasl ldap-sasl "${EPREFIX}"/usr)
+       $(use_with   libedit libedit "${EPREFIX}"/usr)
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
@@ -377,6 +378,7 @@ src_configure() {
        $(use_enable posix posix )
        $(use_with   postgres pgsql "${EPREFIX}"/usr)
        $(use_with   spell pspell "${EPREFIX}"/usr)
+       $(use_with   readline readline "${EPREFIX}"/usr)
        $(use_with   recode recode "${EPREFIX}"/usr)
        $(use_enable sharedmem shmop )
        $(use_enable simplexml simplexml )
@@ -470,11 +472,6 @@ src_configure() {
                fi
        fi
 
-       # readline/libedit support
-       my_conf+="
-       $(use_with readline readline ${EPREFIX}/usr)
-       $(use_with libedit libedit ${EPREFIX}/usr)"
-
        # Session support
        if use session ; then
                my_conf+="