]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Add the pdo-pgsql USE flag.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 82182e2f37fca52185487a439a391c0e989fda87..a0e6dae00ee0a68792155f802ccfb72f2783bad7 100644 (file)
@@ -69,8 +69,8 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit mhash
        mssql mysql libmysqlclient mysqli nls
-       oci8-instant-client odbc +opcache pcntl pdo +phar +posix postgres qdbm
-       readline recode selinux +session sharedmem
+       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-pgsql
+       +phar +posix postgres qdbm readline recode selinux +session sharedmem
        +simplexml snmp soap sockets spell sqlite ssl
        sybase-ct sysvipc systemd tidy +tokenizer truetype unicode vpx wddx
        +xml xmlreader xmlwriter xmlrpc xpm xslt zip zlib"
@@ -178,6 +178,8 @@ REQUIRED_USE="
                pdo
        ) )
 
+       pdo-dblib? ( mssql )
+       pdo-pgsql? ( postgres )
        qdbm? ( !gdbm )
        readline? ( !libedit )
        recode? ( !imap !mysql !mysqli )
@@ -357,11 +359,15 @@ src_configure() {
        $(use_with   gmp gmp "${EPREFIX}"/usr)
        $(use_enable hash hash )
        $(use_with   iconv iconv $(use elibc_glibc || echo "${EPREFIX}"/usr))
+       $(use_with   imap imap "${EPREFIX}"/usr)
        $(use_enable intl intl )
        $(use_with   iodbc iodbc "${EPREFIX}"/usr)
        $(use_enable ipv6 ipv6 )
        $(use_enable json json )
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
+       $(use_with   ldap ldap "${EPREFIX}"/usr)
+       $(use_with   ldap-sasl ldap-sasl "${EPREFIX}"/usr)
+       $(use_with   libedit libedit "${EPREFIX}"/usr)
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
@@ -370,10 +376,13 @@ src_configure() {
        $(use_enable opcache opcache )
        $(use_enable pcntl pcntl )
        $(use_enable pdo pdo )
+       $(use_with   pdo-dblib pdo-dblib )
+       $(use_with   pdo-pgsql pdo-pgsql )
        $(use_enable phar phar )
        $(use_enable posix posix )
        $(use_with   postgres pgsql "${EPREFIX}"/usr)
        $(use_with   spell pspell "${EPREFIX}"/usr)
+       $(use_with   readline readline "${EPREFIX}"/usr)
        $(use_with   recode recode "${EPREFIX}"/usr)
        $(use_enable sharedmem shmop )
        $(use_enable simplexml simplexml )
@@ -432,18 +441,9 @@ src_configure() {
        my_conf+="
        $(use_with gd gd)"
 
-       # IMAP support
+       # IMAP SSL support
        if use imap ; then
-               my_conf+="
-               $(use_with imap imap ${EPREFIX}/usr)
-               $(use_with ssl imap-ssl ${EPREFIX}/usr)"
-       fi
-
-       # LDAP support
-       if use ldap ; then
-               my_conf+="
-               $(use_with ldap ldap ${EPREFIX}/usr)
-               $(use_with ldap-sasl ldap-sasl ${EPREFIX}/usr)"
+               my_conf+="$(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
        # MySQL support
@@ -465,9 +465,7 @@ src_configure() {
        # PDO support
        if use pdo ; then
                my_conf+="
-               $(use_with mssql pdo-dblib )
                $(use_with mysql pdo-mysql ${mysqllib})
-               $(use_with postgres pdo-pgsql )
                $(use_with sqlite pdo-sqlite ${EPREFIX}/usr)
                $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)"
                if use oci8-instant-client ; then
@@ -476,11 +474,6 @@ src_configure() {
                fi
        fi
 
-       # readline/libedit support
-       my_conf+="
-       $(use_with readline readline ${EPREFIX}/usr)
-       $(use_with libedit libedit ${EPREFIX}/usr)"
-
        # Session support
        if use session ; then
                my_conf+="