]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Fix IUSE typo and add "pdo" as a required USE for all of the pdo-* flags.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index e8cfae0d02c26412873101415313fa78d1b9ab14..60dcae9c6f06934b4027edee2f9efa3aa04ccd35 100644 (file)
@@ -69,9 +69,9 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit mhash
        mssql mysql libmysqlclient mysqli nls
-       oci8-instant-client odbc +opcache pcntl pdo +phar +posix postgres qdbm
-       readline recode selinux +session sharedmem
-       +simplexml snmp soap sockets spell sqlite ssl
+       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-mysql pdo-oci
+       pdo-odbc pdo-pgsql pdo-sqlite +phar +posix postgres qdbm readline recode
+       selinux +session sharedmem +simplexml snmp soap sockets spell sqlite ssl
        sybase-ct sysvipc systemd tidy +tokenizer truetype unicode vpx wddx
        +xml xmlreader xmlwriter xmlrpc xpm xslt zip zlib"
 
@@ -175,9 +175,15 @@ REQUIRED_USE="
        libmysqlclient? ( || (
                mysql
                mysqli
-               pdo
+               pdo-mysql
        ) )
 
+       pdo-dblib? ( pdo mssql )
+       pdo-oci? ( pdo oci8-instant-client )
+       pdo-odbc? ( pdo odbc )
+       pdo-mysql? ( pdo mysql )
+       pdo-pgsql? ( pdo postgres )
+       pdo-sqlite? ( pdo sqlite )
        qdbm? ( !gdbm )
        readline? ( !libedit )
        recode? ( !imap !mysql !mysqli )
@@ -363,6 +369,9 @@ src_configure() {
        $(use_enable ipv6 ipv6 )
        $(use_enable json json )
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
+       $(use_with   ldap ldap "${EPREFIX}"/usr)
+       $(use_with   ldap-sasl ldap-sasl "${EPREFIX}"/usr)
+       $(use_with   libedit libedit "${EPREFIX}"/usr)
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
@@ -371,10 +380,16 @@ src_configure() {
        $(use_enable opcache opcache )
        $(use_enable pcntl pcntl )
        $(use_enable pdo pdo )
+       $(use_with   pdo-dblib pdo-dblib )
+       $(use_with   pdo-oci pdo-oci )
+       $(use_with   pdo-odbc pdo-odbc unixODBC,"${EPREFIX}"/usr)
+       $(use_with   pdo-pgsql pdo-pgsql )
+       $(use_with   pdo-sqlite pdo-sqlite "${EPREFIX}"/usr)
        $(use_enable phar phar )
        $(use_enable posix posix )
        $(use_with   postgres pgsql "${EPREFIX}"/usr)
        $(use_with   spell pspell "${EPREFIX}"/usr)
+       $(use_with   readline readline "${EPREFIX}"/usr)
        $(use_with   recode recode "${EPREFIX}"/usr)
        $(use_enable sharedmem shmop )
        $(use_enable simplexml simplexml )
@@ -438,13 +453,6 @@ src_configure() {
                my_conf+="$(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
-       # LDAP support
-       if use ldap ; then
-               my_conf+="
-               $(use_with ldap ldap ${EPREFIX}/usr)
-               $(use_with ldap-sasl ldap-sasl ${EPREFIX}/usr)"
-       fi
-
        # MySQL support
        local mysqllib="mysqlnd"
        local mysqlilib="mysqlnd"
@@ -461,24 +469,8 @@ src_configure() {
                my_conf+="${mysqlsock}"
        fi
 
-       # PDO support
-       if use pdo ; then
-               my_conf+="
-               $(use_with mssql pdo-dblib )
-               $(use_with mysql pdo-mysql ${mysqllib})
-               $(use_with postgres pdo-pgsql )
-               $(use_with sqlite pdo-sqlite ${EPREFIX}/usr)
-               $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)"
-               if use oci8-instant-client ; then
-                       my_conf+="
-                       $(use_with oci8-instant-client pdo-oci)"
-               fi
-       fi
-
-       # readline/libedit support
-       my_conf+="
-       $(use_with readline readline ${EPREFIX}/usr)
-       $(use_with libedit libedit ${EPREFIX}/usr)"
+       # MySQL PDO support
+       my_conf+="$(use_with pdo-mysql pdo-mysql ${mysqllib})"
 
        # Session support
        if use session ; then