]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Remove redundant "if use ldap" check.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index e8cfae0d02c26412873101415313fa78d1b9ab14..371a080e99cd06b1290e4a48b81bc5c3427b69b3 100644 (file)
@@ -363,6 +363,8 @@ src_configure() {
        $(use_enable ipv6 ipv6 )
        $(use_enable json json )
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
+       $(use_with   ldap ldap "${EPREFIX}"/usr)
+       $(use_with   ldap-sasl ldap-sasl "${EPREFIX}"/usr)
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
@@ -438,13 +440,6 @@ src_configure() {
                my_conf+="$(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
-       # LDAP support
-       if use ldap ; then
-               my_conf+="
-               $(use_with ldap ldap ${EPREFIX}/usr)
-               $(use_with ldap-sasl ldap-sasl ${EPREFIX}/usr)"
-       fi
-
        # MySQL support
        local mysqllib="mysqlnd"
        local mysqlilib="mysqlnd"