]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Add the pdo-oci USE flag.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 371a080e99cd06b1290e4a48b81bc5c3427b69b3..13728e1364674e6275e908319fb3e0efcfdc4789 100644 (file)
@@ -69,9 +69,9 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit mhash
        mssql mysql libmysqlclient mysqli nls
-       oci8-instant-client odbc +opcache pcntl pdo +phar +posix postgres qdbm
-       readline recode selinux +session sharedmem
-       +simplexml snmp soap sockets spell sqlite ssl
+       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-oci pdo-odbc
+       pdo-pgsql pdo-sqlite+phar +posix postgres qdbm readline recode selinux
+       +session sharedmem +simplexml snmp soap sockets spell sqlite ssl
        sybase-ct sysvipc systemd tidy +tokenizer truetype unicode vpx wddx
        +xml xmlreader xmlwriter xmlrpc xpm xslt zip zlib"
 
@@ -178,6 +178,11 @@ REQUIRED_USE="
                pdo
        ) )
 
+       pdo-dblib? ( mssql )
+       pdo-oci? ( oci8-instant-client )
+       pdo-odbc? ( odbc )
+       pdo-pgsql? ( postgres )
+       pdo-sqlite? ( sqlite )
        qdbm? ( !gdbm )
        readline? ( !libedit )
        recode? ( !imap !mysql !mysqli )
@@ -365,6 +370,7 @@ src_configure() {
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
        $(use_with   ldap ldap "${EPREFIX}"/usr)
        $(use_with   ldap-sasl ldap-sasl "${EPREFIX}"/usr)
+       $(use_with   libedit libedit "${EPREFIX}"/usr)
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
@@ -373,10 +379,16 @@ src_configure() {
        $(use_enable opcache opcache )
        $(use_enable pcntl pcntl )
        $(use_enable pdo pdo )
+       $(use_with   pdo-dblib pdo-dblib )
+       $(use_with   pdo-oci pdo-oci )
+       $(use_with   pdo-odbc pdo-odbc unixODBC,"${EPREFIX}"/usr)
+       $(use_with   pdo-pgsql pdo-pgsql )
+       $(use_with   pdo-sqlite pdo-sqlite "${EPREFIX}"/usr)
        $(use_enable phar phar )
        $(use_enable posix posix )
        $(use_with   postgres pgsql "${EPREFIX}"/usr)
        $(use_with   spell pspell "${EPREFIX}"/usr)
+       $(use_with   readline readline "${EPREFIX}"/usr)
        $(use_with   recode recode "${EPREFIX}"/usr)
        $(use_enable sharedmem shmop )
        $(use_enable simplexml simplexml )
@@ -458,23 +470,9 @@ src_configure() {
 
        # PDO support
        if use pdo ; then
-               my_conf+="
-               $(use_with mssql pdo-dblib )
-               $(use_with mysql pdo-mysql ${mysqllib})
-               $(use_with postgres pdo-pgsql )
-               $(use_with sqlite pdo-sqlite ${EPREFIX}/usr)
-               $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)"
-               if use oci8-instant-client ; then
-                       my_conf+="
-                       $(use_with oci8-instant-client pdo-oci)"
-               fi
+               my_conf+="$(use_with mysql pdo-mysql ${mysqllib})"
        fi
 
-       # readline/libedit support
-       my_conf+="
-       $(use_with readline readline ${EPREFIX}/usr)
-       $(use_with libedit libedit ${EPREFIX}/usr)"
-
        # Session support
        if use session ; then
                my_conf+="