]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Add the pdo-oci USE flag.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 1f6d8e35b74e8e0d038c0255b241cdcc8846eafc..13728e1364674e6275e908319fb3e0efcfdc4789 100644 (file)
@@ -69,7 +69,7 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit mhash
        mssql mysql libmysqlclient mysqli nls
-       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-odbc
+       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-oci pdo-odbc
        pdo-pgsql pdo-sqlite+phar +posix postgres qdbm readline recode selinux
        +session sharedmem +simplexml snmp soap sockets spell sqlite ssl
        sybase-ct sysvipc systemd tidy +tokenizer truetype unicode vpx wddx
@@ -179,6 +179,7 @@ REQUIRED_USE="
        ) )
 
        pdo-dblib? ( mssql )
+       pdo-oci? ( oci8-instant-client )
        pdo-odbc? ( odbc )
        pdo-pgsql? ( postgres )
        pdo-sqlite? ( sqlite )
@@ -379,6 +380,7 @@ src_configure() {
        $(use_enable pcntl pcntl )
        $(use_enable pdo pdo )
        $(use_with   pdo-dblib pdo-dblib )
+       $(use_with   pdo-oci pdo-oci )
        $(use_with   pdo-odbc pdo-odbc unixODBC,"${EPREFIX}"/usr)
        $(use_with   pdo-pgsql pdo-pgsql )
        $(use_with   pdo-sqlite pdo-sqlite "${EPREFIX}"/usr)
@@ -469,10 +471,6 @@ src_configure() {
        # PDO support
        if use pdo ; then
                my_conf+="$(use_with mysql pdo-mysql ${mysqllib})"
-               if use oci8-instant-client ; then
-                       my_conf+="
-                       $(use_with oci8-instant-client pdo-oci)"
-               fi
        fi
 
        # Session support