]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Add the pdo-mysql USE flag.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index ee5945936a8d34751e4eab0ec54d81dd21fbcbbb..004aae4aae4466266dbf42a5c7354ef4a98e5d2a 100644 (file)
@@ -69,9 +69,9 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit mhash
        mssql mysql libmysqlclient mysqli nls
-       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-pgsql pdo-sqlite
-       +phar +posix postgres qdbm readline recode selinux +session sharedmem
-       +simplexml snmp soap sockets spell sqlite ssl
+       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-mysql pdo-oci
+       pdo-odbc pdo-pgsql pdo-sqlite+phar +posix postgres qdbm readline recode
+       selinux +session sharedmem +simplexml snmp soap sockets spell sqlite ssl
        sybase-ct sysvipc systemd tidy +tokenizer truetype unicode vpx wddx
        +xml xmlreader xmlwriter xmlrpc xpm xslt zip zlib"
 
@@ -175,10 +175,13 @@ REQUIRED_USE="
        libmysqlclient? ( || (
                mysql
                mysqli
-               pdo
+               pdo-mysql
        ) )
 
        pdo-dblib? ( mssql )
+       pdo-oci? ( oci8-instant-client )
+       pdo-odbc? ( odbc )
+       pdo-mysql? ( mysql )
        pdo-pgsql? ( postgres )
        pdo-sqlite? ( sqlite )
        qdbm? ( !gdbm )
@@ -378,6 +381,8 @@ src_configure() {
        $(use_enable pcntl pcntl )
        $(use_enable pdo pdo )
        $(use_with   pdo-dblib pdo-dblib )
+       $(use_with   pdo-oci pdo-oci )
+       $(use_with   pdo-odbc pdo-odbc unixODBC,"${EPREFIX}"/usr)
        $(use_with   pdo-pgsql pdo-pgsql )
        $(use_with   pdo-sqlite pdo-sqlite "${EPREFIX}"/usr)
        $(use_enable phar phar )
@@ -464,16 +469,8 @@ src_configure() {
                my_conf+="${mysqlsock}"
        fi
 
-       # PDO support
-       if use pdo ; then
-               my_conf+="
-               $(use_with mysql pdo-mysql ${mysqllib})
-               $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)"
-               if use oci8-instant-client ; then
-                       my_conf+="
-                       $(use_with oci8-instant-client pdo-oci)"
-               fi
-       fi
+       # MySQL PDO support
+       my_conf+="$(use_with pdo-mysql pdo-mysql ${mysqllib})"
 
        # Session support
        if use session ; then