]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - sci-mathematics/rw/rw-0.7.ebuild
sci-mathematics/rw: commit kiwifb's changes from sage-on-gentoo.
[mjo-overlay.git] / sci-mathematics / rw / rw-0.7.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit autotools-utils
8
9 DESCRIPTION="Compute rank-width decompositions of graphs"
10 AUTHORPAGE="http://pholia.tdi.informatik.uni-frankfurt.de/~philipp/"
11 HOMEPAGE="${AUTHORPAGE}software/${PN}.shtml"
12 SRC_URI="${AUTHORPAGE}/software/${P}.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
17 IUSE="+executable static-libs"
18
19 DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
20 RDEPEND="${DEPEND}"
21
22 DOCDIR="/usr/share/doc/${PF}"
23
24 AUTOTOOLS_IN_SOURCE_BUILD=1
25
26 src_configure(){
27 local myeconfargs=(
28 $(use_enable executable)
29 --docdir="${EPREFIX}${DOCDIR}"
30 )
31
32 autotools-utils_src_configure
33 }
34
35 src_install(){
36 # The examples graphs are meant to be fed uncompressed into the 'rw'
37 # program. The rest of the docs are small so just leave everything
38 # uncompressed.
39 docompress -x "${DOCDIR}"
40 autotools-utils_src_install
41 }