]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - sci-mathematics/rw/rw-0.7.ebuild
Finish (?) sci-mathematics/rw ebuild.
[mjo-overlay.git] / sci-mathematics / rw / rw-0.7.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 DESCRIPTION="Compute rank-width decompositions of graphs"
8 AUTHORPAGE="http://pholia.tdi.informatik.uni-frankfurt.de/~philipp/"
9 HOMEPAGE="${AUTHORPAGE}software/${PN}.shtml"
10 SRC_URI="${AUTHORPAGE}/software/${P}.tar.gz"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE="+executable"
16
17 DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
18 RDEPEND="${DEPEND}"
19
20 DOCDIR="/usr/share/doc/${PF}"
21
22 src_configure(){
23 econf $(use_enable executable) \
24 --docdir="${EPREFIX}${DOCDIR}"
25 }
26
27 src_install(){
28 # This isn't strictly necessary, but it keeps the examples separated
29 # in a subdirectory. It also prevents the example graphs from being
30 # compressed, which is good, since they're supposed to be fed into
31 # the 'rw' program and it doesn't understand bzip2.
32 emake DESTDIR="${D}" install-exec
33 dodoc AUTHORS README NEWS
34
35 insinto "${DOCDIR}"
36 docompress -x "${DOCDIR}/example_graphs"
37 doins -r example_graphs
38 }