]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - net-analyzer/nagios-check_mysql_health/nagios-check_mysql_health-2.1.9.2.ebuild
61e3f70778170a15df707acaa274c7ded22989e6
[mjo-overlay.git] / net-analyzer / nagios-check_mysql_health / nagios-check_mysql_health-2.1.9.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit multilib user
8
9 MY_PN="${PN#nagios-}"
10 MY_P="${MY_PN}-${PV}"
11
12 DESCRIPTION="A nagios plugin for checking MySQL server health"
13 HOMEPAGE="https://labs.consol.de/nagios/${MY_PN}/"
14 SRC_URI="https://labs.consol.de/assets/downloads/nagios/${MY_P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 # Found by grepping for "use " in the built
22 # plugins-scripts/check_mysql_health.
23 RDEPEND="dev-perl/DBD-mysql
24 dev-perl/DBI
25 virtual/perl-Data-Dumper
26 virtual/perl-File-Temp
27 virtual/perl-Net-Ping
28 virtual/perl-Time-HiRes"
29
30 S="${WORKDIR}/${MY_P}"
31
32 src_configure(){
33 # Should match net-analyzer/{monitoring,nagios}-plugins.
34 econf --libexecdir="/usr/$(get_libdir)/nagios/plugins"
35 }
36
37 # Here we should have a pkg_preinst() that creates the nagios user/group
38 # (using the same command from e.g. net-analyzer/nagios-plugins). But
39 # right now, the build system for check_mysql_health has a bug: it
40 # doesn't use the configured user (INSTALL_OPTIONS aren't passed to
41 # /usr/bin/install), so it's pointless.