Add an "any slot" dependency operator for dev-db/postgresql.
[mjo-overlay.git] / dev-lang / php / files / stricter-libc-client-symlink-check.patch
1 Gentoo bugs: 88944 463800
2 --- ext/imap/config.m4 2013-03-27 19:31:13.000000000 +0100
3 +++ ext/imap/config.m4.new 2013-03-30 18:34:17.581557062 +0100
4 @@ -198,9 +198,9 @@
5 AC_MSG_ERROR(Cannot find rfc822.h. Please check your c-client installation.)
6 fi
7
8 - if test -r "$IMAP_DIR/c-client/c-client.a"; then
9 + if test ! -r "$IMAP_DIR/c-client/libc-client.a" && -r "$IMAP_DIR/c-client/c-client.a" ; then
10 ln -s "$IMAP_DIR/c-client/c-client.a" "$IMAP_DIR/c-client/libc-client.a" >/dev/null 2>&1
11 - elif test -r "$IMAP_DIR/$PHP_LIBDIR/c-client.a"; then
12 + elif test ! -r "$IMAP_DIR/$PHP_LIBDIR/libc-client.a" && -r "$IMAP_DIR/$PHP_LIBDIR/c-client.a"; then
13 ln -s "$IMAP_DIR/$PHP_LIBDIR/c-client.a" "$IMAP_DIR/$PHP_LIBDIR/libc-client.a" >/dev/null 2>&1
14 fi
15