Add an "any slot" dependency operator for dev-db/postgresql.
[mjo-overlay.git] / dev-lang / php / files / bison_build_2.patch
1 diff --git a/Zend/zend_language_parser.y b/Zend/zend_language_parser.y
2 index ccbc9b1..6a9a24a 100644
3 --- a/Zend/zend_language_parser.y
4 +++ b/Zend/zend_language_parser.y
5 @@ -41,17 +41,19 @@ static YYSIZE_T zend_yytnamerr(char*, const char*);
6
7 #define YYERROR_VERBOSE
8 #define YYSTYPE znode
9 -#ifdef ZTS
10 -# define YYPARSE_PARAM tsrm_ls
11 -# define YYLEX_PARAM tsrm_ls
12 -#endif
13 -
14
15 %}
16
17 %pure_parser
18 %expect 3
19
20 +%code requires {
21 +#ifdef ZTS
22 +# define YYPARSE_PARAM tsrm_ls
23 +# define YYLEX_PARAM tsrm_ls
24 +#endif
25 +}
26 +
27 %token END 0 "end of file"
28 %left T_INCLUDE T_INCLUDE_ONCE T_EVAL T_REQUIRE T_REQUIRE_ONCE
29 %token T_INCLUDE "include (T_INCLUDE)"