Update the supported version of Roundcube.
[mailshears.git] / lib / mailshears.rb
index 30dd71ebc99130aeb0c128a7433fee5d244b57da..bda9f0dd46b0dd20ac5d8b3d3ca243f234b88038 100644 (file)
@@ -1,23 +1,8 @@
-# Load the rest of the code we'll use.
+# Load the rest of the code we'll use. This loads what we'll need in
+# the executables; the library files are supposed to require what they
+# need.
 
-# And the necessary classes.
-require 'mailshears/errors.rb'
-require 'mailshears/exit_codes.rb'
-require 'mailshears/postfixadmin_db'
-
-# Load the default config file first, and let the user override it.
-require 'default_configuration'
-
-begin
-  # Try to load the user's configuration file.
-  userconf_path = ENV['HOME'] + '/.mailshears.conf'
-  require userconf_path
-rescue
-  puts 'No user configuration file (~/.mailshears.conf) found.'
-  puts 'Continuing...'
-end
-
-Configuration::PLUGINS.each do |plugin_file|
-  require "mailshears/plugins/#{plugin_file}"
-end
+require 'common/configuration'
+require 'common/errors'
+require 'common/exit_codes'