Begin updating docs; remove two unused exit codes.
[mailshears.git] / lib / mailshears.rb
index 75e38f0927df7c32df1099805b34a23b0820d430..55a87f8324918f317b8c4b893ef752165f77bad8 100644 (file)
@@ -1,11 +1,7 @@
-# Load the rest of the code we'll use.
-
-# And the necessary classes.
-require 'mailshears/errors.rb'
-require 'mailshears/exit_codes.rb'
-require 'mailshears/postfixadmin_db'
-
-Configuration::PLUGINS.each do |plugin_file|
-  require "mailshears/plugins/#{plugin_file}"
-end
+# Load only the files needed by our executable. The library files are
+# supposed to require what they need themselves.
 
+require 'common/configuration'
+require 'common/errors'
+require 'common/exit_codes'
+require 'common/user_interface'