Begin updating docs; remove two unused exit codes.
[mailshears.git] / lib / mailshears.rb
index 1c8c042632430735c8ea0f38957faee57335bcff..55a87f8324918f317b8c4b893ef752165f77bad8 100644 (file)
@@ -1,18 +1,7 @@
-# Load the rest of the code we'll use. This loads what we'll need in
-# the executables; the library files are supposed to require what they
-# need.
+# Load only the files needed by our executable. The library files are
+# supposed to require what they need themselves.
 
 require 'common/configuration'
 require 'common/errors'
 require 'common/exit_codes'
-require 'common/postfixadmin_db'
-
-cfg = Configuration.new()
-
-cfg.plugins.each do |plugin_file|
-  require "rm/plugins/#{plugin_file}"
-end
-
-cfg.plugins.each do |plugin_file|
-  require "mv/plugins/#{plugin_file}"
-end
+require 'common/user_interface'