662abff73e89d1b176a97b4cea8d780415eec3bf
[mailshears.git] / lib / mv / mv_dummy_runner.rb
1 require 'common/runner'
2
3 class MvDummyRunner
4 include Runner
5
6 def run(plugin, src, dst)
7
8 if src.is_a?(Domain) or dst.is_a?(Domain) then
9 msg = 'only users can be moved'
10 raise NotImplementedError.new(msg)
11 end
12
13 puts "Would move user #{src.to_s()} to #{dst.to_s()}."
14 end
15
16 end