Require dns >= 1.4 and use its 'normalize' function.